Frequent frame skipping on high end PC

  • I have a really solid rig, and yet I CONTINUE to get random stutters when things happen in-game. I'll go from > 144 fps, it will freeze for a moment, then go down to 10 fps and pop back up to 144. I've noticed in my Task Manager, that the processor usage will drop all the way down as well, then pop back up... All other games seem to run just fine with no skipping or frame drops whatsoever. I'm super confused, and have tried quite a few things:

    I've tried altering 3D Settings in the NVidia Control Panel

    I've deleted the "Cache" and "Logs" folders that most people recommend

    I've set the Hearthstone process to high priority

    I've ensured that nothing else is using up a ton of memory whilst I'm playing

    I've checked my power settings, updated drivers... Nothing works

    Any ideas?

    Here are my specs (Windows 10):

    Intel Core i7-8700K @ 3.70GHz

    16 GB DDR4 RAM

    NVIDIA GeForce GTX 1070 Ti Turbo

    ADATA SX6000NP - 1TB

    Samsung SSD 850 EVO - 250GB

    ST2000DM006-2DM164
  • Hey Necrode,

    Seems like you've covered a lot of stuff already, so let's get a DxDiag so we can take a closer look:

    1) Press Windows Key + R.
    2) Type DxDiag and press Enter.
    3) In the DxDiag window, click Save All Information.
    4) Name the file "dxdiag" and click Save
    5) Paste the DxDiag into a new post, select and highlight everything you just pasted, and hit the "code" button (</>). That'll make the information much more readable.

    If you have issues pasting here, please use Pastebin and post the link.
  • Hey Necrode,

    Is Hearthstone installed on the Evo drive? Do you experience the same problems if Hearthstone is installed on a different harddrive? It also looks like the Nvidia driver may be having some problems, so you could try a clean driver install. To do this, uninstall the current driver by using DDU. You can find a guide for using this software here. After the driver has been removed, download the latest driver by going here.

    Hey Trick2g,

    It looks like your Nvidia driver is using an older version (23.21.13.8813). I would suggest following the driver steps above, and getting the current driver from here.