Update

  • So today when i entered hs it started an update,everything worked fine.But when i exited the game and try to enter again it says that i need to update,but when i try to it says whoops looks like something broke,try again.How to fix this?
  • Hi there Djuka92,

    At a quick glance, I know this issue can be caused by a plethora of causes. The first thing I would think is an active firewall. If you have an Anti-Virus installed on the system, I would ask you to temporarily disable the active firewall.

    Most of the time this can be done by right clicking the Anti-Virus icon in the System tray. The System tray is marked by ^ on the task bar. Once right clicked, turning off active or smart firewalls is the option you will want. If this does not work, then please turn it back on.

    Next, I would want to fully reset the Blizzard app if you still have issues.
    Perform Steps 1-5 here after that do not reinstall yet but follow these additional steps:

      1. Open file explorer/file manager
      2. Type the following into the address bar (not the search bar): %APPDATA%
      3. Delete the Bnet and blizzard folders inside the appdata folder if they exist.
      4. Repeat steps 2 and 3 with %LOCALAPPDATA% and %TEMP%
      5. Empty the recycle bin.


    If nothing else here helps, please post back with a DxDiag.

    DxDiag:

      1. Press Windows Key + R.
      2. Type DxDiag and press Enter.
      3. In the DxDiag window, click Save All Information.
      4. Name the file "dxdiag" and click Save
      5. Paste the DXdiag into the post, select and highlight everything you just pasted, and hit the "code" button (</>). That'll make the information much more readable.


    /Nathardrick