Game won't start on MAC, non-responsive

  • After few years now playing on my MAC book air without any issue I find my self with a non responsive game. I can not start the game, it just quits few seconds after pressing "PLAY". I have tried everything I could find online- deleting Library files, the whole game, the Client- everything. Latest update did not help what so ever. I have several friends and I saw it all over the USA forums- many people have this issue and there are no solutions. It feels horrible that I spend a vast amount of cash on the game last months and I am finally about to hit legendary, but hey! My damn game wont start for weeks now. Anyone figured it out? Can we get any news on a fix?
  • Hey there Vulgaels,

    I looked over your crash and it seems it may be related to the client failing to download the needed information. Based on the steps you tried here, I would try another connection to re download the game.

    If you are going to stay on the same connection, I would ask you try and configure the ports and power cycle.

    *note* this is for the crash your system sent to us when you crashed. If you have other crashes, please reach out to us. :)

    /Nathardrick